PHP 8.4: Curl: Minimum required libcurl version increased to 7.61.0


The Curl extension exposes libcurl functionality in PHP. While it is possible to compile The Curl extension with any supported libcurl version, the extension requires a certain minimum libcurl version. This makes it easier for the extension to ensure that certain functionality and APIs are always available.

Prior to PHP 8.4, the Curl extension required libcurl version 7.29.0 (released in 2013) or higher. In PHP 8.4 and later, the Curl extension requires libcurl version 7.61.0 (released in 2018) or later.

This minimum requirement bump is made with the consideration of Linux distributions such as RHEL 7, CentOS 7, and Ubuntu 18 reaching their End Of Life dates by the time PHP 8.4 is released.

At the PHP 8.4 release time, all current Linux-based operating systems that provide the libcurl-dev or libcurl-devel package in their default software repositories provide libcurl 7.61.0 and later, which means this change should not require any changes as long as the operating systems are current and supported.

Distro name libcurl version EOL Date
Debian buster 7.64 2024 June
Ubuntu 20.04 7.68 2025 April
RHEL 7/CentOS 7 7.29 2024 June
Fedora 38 7.87 rolling release

Even in the old PHP distributions that provide an old libcurl version, the Curl extension can be compiled with a different libcurl version. Examples for compiling PHP on Ubuntu/Debian and Fedora/RHEL provide more information.

Backward Compatibility Impact

This change bumps the minimum supported libcurl version for the Curl extension to libcurl 7.61.0. This version was released in 2018, and all current operating systems provide a newer libcurl version than 7.61.0.

Even on operating systems that provide an older libcurl version, or systems that do not provide libcurl at all, it is possible to compile the Curl extension with any libcurl version, as long as it is 7.61.0 or later.